确定了一下, 免费用户连5.15的源代码也无法获取了

iwantfly
雷雷 06月30日 字数 44

到 qt 的 git 上看看

没有 5.15.3, 5.15.4的源码

KDE_Qt KDE与Qt编程技术
16 个回复
idoppler
idoppler 06月30日
zhcon
buyaolian 06月30日

是的

【 在 iwantfly 的大作中提到: 】

: 到 qt 的 git 上看看

: 没有 5.15.3, 5.15.4的源码

cn62
cn62 06月30日

不用Qt了,关注下rust的几个ui库,druid/iced。

【 在 iwantfly 的大作中提到: 】

: 到 qt 的 git 上看看

: 没有 5.15.3, 5.15.4的源码

cavendish
享受生活 07月01日

5.15.2之后,5.15分支就对外关闭了

请参考 https://www.qt.io/blog/commercial-lts-qt-5.15.3-released

开源用户可以使用kde维护的5.15分支

https://community.kde.org/Qt5PatchCollection

【 在 iwantfly 的大作中提到: 】

: 到 qt 的 git 上看看

: 没有 5.15.3, 5.15.4的源码

hgoldfish
老鱼 07月01日

直接用 git repo 可行不?还是说 git repo 都没有了?

【 在 iwantfly (雷雷) 的大作中提到: 】

: 到 qt 的 git 上看看

: 没有 5.15.3, 5.15.4的源码

atzlinux
atzlinux 07月02日

感觉现在  QT 的搞法是拿一个版本出来,前期开源,让开源社区帮忙测试、反馈、定位 bug。

然后再发布一个商业的 bug 修复版本,你爱买不买了。

【 在 cavendish (享受生活) 的大作中提到: 】

: 5.15.2之后,5.15分支就对外关闭了

: 请参考 https://www.qt.io/blog/commercial-lts-qt-5.15.3-released

: 开源用户可以使用kde维护的5.15分支

: ...................

hgoldfish
老鱼 07月02日

也不要太神话 LTS 补丁,里面都是一些小细节。其实不太重要。

你看 WPS 一直到最近才换成 Qt5 呢。

除了 LTS 版本,其它 Qt 版本,商业用户和开源用户拿到的都是一样的。

我感觉国内还是很排斥自由软件社区搞商业化。不应该的啊。

【 在 atzlinux (atzlinux) 的大作中提到: 】

: 感觉现在  QT 的搞法是拿一个版本出来,前期开源,让开源社区帮忙测试、反馈、定位 bug。

: 然后再发布一个商业的 bug 修复版本,你爱买不买了。

zhcon
buyaolian 07月02日

也是,况且QWidgets已经很久没加东西了

【 在 hgoldfish 的大作中提到: 】

: 也不要太神话 LTS 补丁,里面都是一些小细节。其实不太重要。

: 你看 WPS 一直到最近才换成 Qt5 呢。

: 除了 LTS 版本,其它 Qt 版本,商业用户和开源用户拿到的都是一样的。

: ...................

hgoldfish
老鱼 07月02日

QtWidgets 已经多年不更新了唉。。

像 loading 控件这种,按说应该内置一下。

【 在 zhcon (buyaolian) 的大作中提到: 】

: 也是,况且QWidgets已经很久没加东西了

xieyf
绿蚁新醅酒,红泥小火炉 07月04日

到kde的源代码中看看

【 在 iwantfly 的大作中提到: 】

: 到 qt 的 git 上看看

: 没有 5.15.3, 5.15.4的源码

cavendish
享受生活 07月06日

dev以及6.x都还是开放的

6.2这个lts应该也是发布后6个月关闭

dev里如果能找到这个bug的fix

自己试着cherry-pick

或者在dev里

git log --grep=5.15

hgoldfish
老鱼 07月06日

6.2 也是 lts ?

KDE 这一块,有没有听说要怎么跟上 Qt6 ?

【 在 cavendish (享受生活) 的大作中提到: 】

: dev以及6.x都还是开放的

: 6.2这个lts应该也是发布后6个月关闭

: dev里如果能找到这个bug的fix

: ...................

lobachevsky
罗巴切夫斯基 07月06日

我的问题是

如果我拿到opensource的源代码,自己编译一遍,然后拿来用

算不算d版

【 在 hgoldfish 的大作中提到: 】

: 6.2 也是 lts ?

: KDE 这一块,有没有听说要怎么跟上 Qt6 ?

hgoldfish
老鱼 07月06日

当然不算。Qt 是开源的。Qt 收费的是服务,其中包括安装器打包服务。

【 在 lobachevsky (罗巴切夫斯基) 的大作中提到: 】

: 我的问题是

: 如果我拿到opensource的源代码,自己编译一遍,然后拿来用

: 算不算d版

: ...................

niuba
牛吧 07月06日

都是套路。

发自「今日水木 on Redmi Note 7」

【 在 atzlinux 的大作中提到: 】

: 感觉现在 QT 的搞法是拿一个版本出来,前期开源,让开源社区帮忙测试、反馈、定位 bug。

: 然后再发布一个商业的 bug 修复版本,你爱买不买了。

: --

: 铜豌豆 Linux

https://www.atzlinux.com

: 基于 Debian 的 Linux 中文桌面操作系统

: 铜豌豆软件源:Debian 系发行版 中文软件

https://www.atzlinux.com/allpackages.htm

miui
miui 昨天 12:52

弱问这个Patch怎么用?我把kde/5.15分支的文件下载以后覆盖官方源码qt-everywhere

-src-5.15.2.zip中qtbase目录下文件,单独编译qtbase会报错

c:\package\qt\qt-everywhere-src-5.15.2\qtbase\src\corelib\global\qglobal_p.h

(59): fatal error C1083: Cannot open include file: 'QtCore/private/qconfig_p

.h': No such file or directory

【 在 cavendish (享受生活) 的大作中提到: 】

: 5.15.2之后,5.15分支就对外关闭了

: 请参考 https://www.qt.io/blog/commercial-lts-qt-5.15.3-released

: 开源用户可以使用kde维护的5.15分支

: ...................